De ellende die Youtube heet

Door SomerenV op donderdag 7 juni 2018 02:32 - Reacties (15)
Categorie: Technology, Views: 5.915

Youtube staat vol interessante video's die allerlei hobbies beslaan. De geek in mij kijkt graag naar de video's van Tested. De gamer in mij kijkt graag naar Easy Allies. Wil ik wat eet-gerelateerde zaken zien? Binging with Babish of Alex the French Cooking Guy. Voor nostalgie ga ik voor LGR en voor de petrolhead in mij reis ik af naar Petrolicious. En wil ik wat slap geouwehoer met hier en daar een kritische noot dan pak ik H3H3 erbij.

Genoeg te zien dus op Youtube, het platform waarop 300 uur aan video per minuut wordt geüpload. Zelf bekijk ik de video's via Chrome. Youtube is van Google, Chrome ook. Match made in heaven dus!

https://i.imgur.com/MwAjv3h.png

[rant]

Geen idee waarom maar sinds lange tijd doet Youtube moeilijk. Niet altijd, maar gewoon random.
  • Dan ben je een video aan het kijken en *poef* buffering. Skippen naar een ander stuk werkt dan niet meer. De pagina refreshen is dan het enige wat werkt.
  • Midden in een video besluiten de kwaliteit te verlagen. Hier heb je wat 360p, gewoon omdat 't kan!
  • Opeens het beeld voor een paar seconden stil zetten terwijl het geluid verder loopt. Meestal lost dit zichzelf op, maar soms loopt de video gewoon vast en moet de pagina ververst worden.
  • Meerdere keren skippen in een video? Meer dan eens laat dit de player crashen waarna (je raadt het al) de pagina ververst moet worden.
  • Oh, start je een programma van Adobe op? Tijd voor Youtube om er mee te kappen!
Op het internet vind je redelijk wat fora waarin dezelfde soort problemen beschreven worden. Een goede vriend van me heeft er last van en het is gewoon niet op te lossen. Een verse Windows-installatie? Nope. Chrome opnieuw installeren? Nope. Alle plugins verwijderen? Nope. Alleen Chrome open hebben staan en verder niks? Nope. Edge gebruiken? Dat verbetert de zaak een beetje maar Youtube is nog steeds drama van hier tot Tokio.

Als ik dan vervolgens naar Vimeo, Twitch, Netflix of Dumpert ga dan is het smooth sailing. Maakt niet uit wat ik op de PC aan het doen ben, die video's blijven door denderen. Alleen als ik m'n CPU 100% belast tijdens bijvoorbeeld het exporteren van een video dan willen die diensten nog wel eens gaan haperen, maar da's logisch aangezien er dan nul ademruimte over is voor de browser.

Het is dat 99% van de content (Netflix buiten beschouwing gelaten) die ik kijk op Youtube staat anders was ik er al lang vertrokken want wát een dramatisch slecht platform is dat.

[/rant]

In other news: E3 gaat over zo'n twee dagen van start met de persconferentie van EA. It's time to board the hypetrain!

https://i.gifer.com/A5lN.gif

Volgende: E3: reactie van een non-gamer 07-06 E3: reactie van een non-gamer
Volgende: Alcohol tijdens de Ramadan 17-05 Alcohol tijdens de Ramadan

Reacties


Door Tweakers user theblindman, donderdag 7 juni 2018 06:57

Misschien lost een verse installatie van macOS het probleem op? :Y)
Maar even serieus, kun je niet gewoon een andere browser gebruiken?

Door Tweakers user thefal, donderdag 7 juni 2018 08:47

Ik moet zeggen, ik heb nooit ook maar enige last gehad van de combi youtube/chrome, tot een maand geleden. Mijn oplossing voor het eerste probleem: Videoresolutie verhogen of verlagen. Ik kan een hele minuut wachten tot de video weer start, maar zodra ik hem van 720p naar 1080p zet start de video direct weer.

Ik hoop dat de problemen gewoon opgelost worden inderdaad want dit is geen doen zo.

Door Tweakers user Willthor, donderdag 7 juni 2018 10:30

Ik kijk ook regelmatig filmpjes op YouTube via chrome, maar hier echt nog nooit last van gehad.

Door Tweakers user RobIII, donderdag 7 juni 2018 11:31

Dit klinkt anders gewoon alsof je op een gare WiFi zit o.i.d. En omdat je daar 99% van de tijd zit, zoals je zelf aangeeft, merk je problemen dáár i.p.v. op Vimeo / Netflix whatever je noemt (want daar zit je dan die 1% en dus veel kleinere kans dat je dan nét daar 'n probleem hebt). Gevalletje confirmation bias ;)

Ik heb geen van de problemen die je beschrijft op m'n laptop als ik gewoon bekabeld werk. Werk ik op WiFi dat gebeurt 't wel eens dat 'ie gaat bufferen of dat de kwaliteit even omlaag gaat ja.

[Reactie gewijzigd op donderdag 7 juni 2018 11:36]


Door Tweakers user dodge_911, donderdag 7 juni 2018 12:15

Mijn mac mini (late 2012) begint te blazen als 'n gek als'ie 720p60 of hoger moet afspelen.
In Safari heb ik daar hoegenaamd geen last van.

[Reactie gewijzigd op donderdag 7 juni 2018 12:15]


Door Tweakers user SomerenV, donderdag 7 juni 2018 13:10

thefal schreef op donderdag 7 juni 2018 @ 08:47:
Ik moet zeggen, ik heb nooit ook maar enige last gehad van de combi youtube/chrome, tot een maand geleden. Mijn oplossing voor het eerste probleem: Videoresolutie verhogen of verlagen. Ik kan een hele minuut wachten tot de video weer start, maar zodra ik hem van 720p naar 1080p zet start de video direct weer.

Ik hoop dat de problemen gewoon opgelost worden inderdaad want dit is geen doen zo.
Hier is het ook lange tijd best goed gegaan maar de laatst tijd lijkt het erger te zijn geworden. Videoresolutie verhogen of verlagen werkt soms, maar niet altijd helaas.
Willthor schreef op donderdag 7 juni 2018 @ 10:30:
Ik kijk ook regelmatig filmpjes op YouTube via chrome, maar hier echt nog nooit last van gehad.
Dat is dus het rare. Genoeg mensen die er geen last van hebben maar ook een hoop die er wel last van hebben. De oorzaak vinden is om die reden dan ook bijzonder lastig.
RobIII schreef op donderdag 7 juni 2018 @ 11:31:
Dit klinkt anders gewoon alsof je op een gare WiFi zit o.i.d. En omdat je daar 99% van de tijd zit, zoals je zelf aangeeft, merk je problemen dáár i.p.v. op Vimeo / Netflix whatever je noemt (want daar zit je dan die 1% en dus veel kleinere kans dat je dan nét daar 'n probleem hebt). Gevalletje confirmation bias ;)

Ik heb geen van de problemen die je beschrijft op m'n laptop als ik gewoon bekabeld werk. Werk ik op WiFi dat gebeurt 't wel eens dat 'ie gaat bufferen of dat de kwaliteit even omlaag gaat ja.
Ik zit op een bekabelde 100mbps glasvezelverbinding dus dat zal het niet zijn :) Via wifi op de telefoon in de Youtube-app werkt het overigens vlekkeloos ;) En het is geen confirmation bias in dit geval. Op momenten dat Youtube moeilijk gaat doen switch ik regelmatig bij wijze van test naar andere diensten en die blijven dan vrolijk werken, zelfs met redelijke belasting van de PC. Ga ik dan weer terug naar Youtube dan begint de ellende weer.
theblindman schreef op donderdag 7 juni 2018 @ 06:57:
Misschien lost een verse installatie van macOS het probleem op? :Y)
Maar even serieus, kun je niet gewoon een andere browser gebruiken?
In Edge werkt het dus beter dus ik zit er aan te denken volledig over te gaan naar die browser. Maar ook daar wil Youtube wel eens kuren vertonen.

Door Tweakers user onok, donderdag 7 juni 2018 14:34

Ik kijk vrij veel youtube (gemiddeld zo'n 30 mins per dag op pc, en een uurtje per week op de tv) en ik heb hier geen last van. Ik gebruik overigens chrome op Ubuntu. Misschien kun je dat eens proberen :P

Door Tweakers user Calamor, donderdag 7 juni 2018 15:49

Ik kijk ook regelmatig Youtube. (leuk dat je ook naar Binging with Babish kijkt!) In Firefox heb ik nergens last. Had er een keer wel last van maar dat is al heel erg lang geleden, denk wel zo langer dan 4 jaar geleden.
Al heb ik op mijn telefoon wel erg veel last met de Youtube app. En dan vooral laden is erg vervelend op lage resolutie. Dat komt weer door de Wifi. En dat is binnen kort opgelost door dat ik Netgear insight premium kan gaan test. Heb daar heel veel zin in :D

Misschien zitten ze wat te testen Google. Heb het in het verleden dat zoeken in Google heel anders er uit zag. Toen ben ik maar tijdelijk andere duckgogo gegaan.

Misschien een tipje om naar Two Minute Papers te kijken. Erg interessant en de filmpjes duren niet lang.

Door Tweakers user Septimamus, vrijdag 8 juni 2018 11:09

Ik heb precies hetzelfde probleem op mijn Macbook en Windows pc. Allebei in Chrome. De ene keer gaat het prima, de andere keer moet de video bufferen elke 5 seconden. Heel irritant.

Door Tweakers user YourMom, vrijdag 8 juni 2018 11:25

Omwille van diezelfde instabiliteit kijk ik alleen nog Youtube via mobiel of chromecast, dat werkt tenminste.

Door Tweakers user Jorick, vrijdag 8 juni 2018 16:26

Ik denk dat je problemen te herleiden zijn naar het feit dat YouTube in Chrome standaard de VP9 codec gebruikt voor video's, Afhankelijk van het gebruikte platform en de hardware in je PC kan dat voor problemen zorgen. Je kunt dit zien door in YT rechts te klikken op een video en dan op 'statistieken voor nerds' te klikken. Onder Codecs staat dan welke codec er gebruikt wordt. Als je bijvoorbeeld geen GPU hebt die VP9 hardwarematig kan decoderen dan moet alles door de CPU gedaan worden en dat kan een behoorlijke aanslag op je CPU zijn, zeker bij video's met hoge resolutie/framerate/bitrate.

In hoeverre jouw systeem wel/geen hardware accelerated video decoding doet kun je zien via chrome://gpu. Tevens moet de flag "Hardware-accelerated video decode" ingeschakeld zijn bij chrome://flags. Wat je ook kunt proberen is om de h264ify extensie te installeren zodat o.a. op YT standaard de h264 codec i.p.v. VP9 wordt gebruikt.

Zelf werk ik voornamelijk in Ubuntu en daar is voor Chrome standaard geen hardwarematige decodering van video's ingeschakeld, ongeacht of er een videokaart aanwezig is die dit wel ondersteund. Desondanks werkt YT hier zonder problemen en wordt alles via de CPU gedecodeerd. Als video's problemen geven (dropped frames bijvoorbeeld) dan schakel ik over naar Chromium met ondersteuning voor hardware acceleration i.c.m. de h264ify extensie en dat werkt, ondanks dat dit niet officieel ondersteund wordt voor dit platform, probleemloos. Geen last van buffering-issues, haperingen of anderzijds en vrijwel geen CPU-belasting.

[Reactie gewijzigd op vrijdag 8 juni 2018 16:27]


Door Tweakers user xproniels, maandag 11 juni 2018 10:23

heb jij toevallig een ASIO audio driver of ingesteld dat adobe het alleenrecht van je speakers opeist?

Door Tweakers user Ballebek, maandag 11 juni 2018 10:30

SomerenV schreef op donderdag 7 juni 2018 @ 13:10:
Ik zit op een bekabelde 100mbps glasvezelverbinding dus dat zal het niet zijn :)
Ik zit hier met een vers geinstalleerde Windows 10 laptop die via 1 Gbit 3 hops van Youtube zit verwijderd en ook hier heb ik al langere tijd hetzelfde gedrag, met zowel Chrome als Edge.
Ook met mijn mobiel, alleen gebruik ik die niet op het werk. :)

Door Tweakers user SomerenV, maandag 11 juni 2018 13:10

Jorick schreef op vrijdag 8 juni 2018 @ 16:26:
Ik denk dat je problemen te herleiden zijn naar het feit dat YouTube in Chrome standaard de VP9 codec gebruikt voor video's, Afhankelijk van het gebruikte platform en de hardware in je PC kan dat voor problemen zorgen. Je kunt dit zien door in YT rechts te klikken op een video en dan op 'statistieken voor nerds' te klikken. Onder Codecs staat dan welke codec er gebruikt wordt. Als je bijvoorbeeld geen GPU hebt die VP9 hardwarematig kan decoderen dan moet alles door de CPU gedaan worden en dat kan een behoorlijke aanslag op je CPU zijn, zeker bij video's met hoge resolutie/framerate/bitrate.

In hoeverre jouw systeem wel/geen hardware accelerated video decoding doet kun je zien via chrome://gpu. Tevens moet de flag "Hardware-accelerated video decode" ingeschakeld zijn bij chrome://flags. Wat je ook kunt proberen is om de h264ify extensie te installeren zodat o.a. op YT standaard de h264 codec i.p.v. VP9 wordt gebruikt.

Zelf werk ik voornamelijk in Ubuntu en daar is voor Chrome standaard geen hardwarematige decodering van video's ingeschakeld, ongeacht of er een videokaart aanwezig is die dit wel ondersteund. Desondanks werkt YT hier zonder problemen en wordt alles via de CPU gedecodeerd. Als video's problemen geven (dropped frames bijvoorbeeld) dan schakel ik over naar Chromium met ondersteuning voor hardware acceleration i.c.m. de h264ify extensie en dat werkt, ondanks dat dit niet officieel ondersteund wordt voor dit platform, probleemloos. Geen last van buffering-issues, haperingen of anderzijds en vrijwel geen CPU-belasting.
Dit scheelt echt aanzienlijk! Ik heb nu die plugin draaien en het lijkt vooralsnog zonder problemen te werken allemaal. Ik lees her en en der ook dat Chrome/Youtube nog wel eens moeilijk wil doen met een Nvidia GPU (heb zelf een 1060) dus dat kan ook een en ander verklaren. Maar thanks voor de fix :)
xproniels schreef op maandag 11 juni 2018 @ 10:23:
heb jij toevallig een ASIO audio driver of ingesteld dat adobe het alleenrecht van je speakers opeist?
Ging niet om de audio want staat allemaal prima ingesteld. Het was echt Youtube dat er volledig uit klapte (eindeloos bufferen).
Ballebek schreef op maandag 11 juni 2018 @ 10:30:
[...]

Ik zit hier met een vers geinstalleerde Windows 10 laptop die via 1 Gbit 3 hops van Youtube zit verwijderd en ook hier heb ik al langere tijd hetzelfde gedrag, met zowel Chrome als Edge.
Ook met mijn mobiel, alleen gebruik ik die niet op het werk. :)
Ik snap ook echt niet dat een gigantisch bedrijf als Google dat soort dingen niet gewoon op orde kan krijgen. Op m'n telefoon werkt het gelukkig wel prima, maar een PC die moeiteloos zware videobestanden af kan spelen zou ook wel wat Youtube af moeten kunnen spelen zou je zeggen :+

Door Tweakers user gameguy12, woensdag 13 juni 2018 08:41

Op m'n Windows laptop heb ik dat Chrome zo 60 a 80% cpu gebruikt als YouTube open is en soms gaat het ook bufferen wel hinderlijk idd, geen moeite met adobe programma's en youtube

Reactie formulier
(verplicht)
(verplicht, maar wordt niet getoond)
(optioneel)